I suggest you ...

Activate "real" vibration mode

Make it possible to enable the real android vibration-mode that shows the vibration-icon in the status bar. can't get it to work right now, so i think this is a missing feature.

33 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    riccot shared this idea  ·   ·  Admin →
    started  ·  Adminprobeez (Admin, probeez) responded  · 

    actually it’s a bug we could not catch on our device. can someone emails us with details about issue, SP settings backup and phone model info

    11 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Marco Conti commented  · 

        I've installed SP Lite yesterday and try a little. I've made it to apply vibration "only in silent mode" and now, even if I disabled the profile created and also unistalled the application the vibration icon doesn't appear, never. And even if the vibration works righta on the phone the option to activate it from menu of the phone doesn't work! My phone is an HTC Desire Z completely original software.
        How can I turn back to regular settings?!

      • detmer14v1 commented  · 

        Need an option to put phone in vibrate mode. some apps only vibrate notifications if the phone is in vibrate mode. Not just that vibrations for notifications is enabled

      • MinuitPro commented  · 

        I performed the update to 2.1 on my Hero and same problem exists. The main issue is that I can leave Silent mode unchecked and turn down all the volumes and check both Vibrate modes and the Vibrate icon doesn't show - it may be my ignorance but should there instead be a "Vibrate mode" option? If I check the Silent mode option, the Vibrate for calls can remain checked (and works) and the vibrate icon will display, however the Vibrate for notifications cannot be starred; while remaining checked if you checked it before it disables, being unstarred means that notifications don't cause vibration (assuming the previous/default profile didn't have it checked). Hope that helps explain the predicament. If I'm doing something wrong please let me know - but for now I just have to up/down the volume to see the icon reflect what the settings are actually doing. It's just a UI issue (functionality works correctly).

      • rokair commented  · 

        The Vibration Icon shows on the Sprint Hero for the Default Profile (once not set to default and/or if the Profile even while set to Default is Activated manually or by a rule the Icon no longer shows correct but instead just the silent icon). Again, not unworkable but I did have to get very creative with my logic to work around it.

      • MinuitPro commented  · 

        As gpoete/Steven stated you get two options:
        1) True vibrate is not on (i.e. for noifications) but you can see the icon w/ silent mode starred. (Silent for some reason disables ability to star vibration for notifications)
        2) Silent mode is off, all the volumes are turned down, vibrates are turned on but the icon doesn't appear unless you manually up & down the volume after toggling the profile.

        I would gladly offer specs on my Hero but I don't know what all probeez needs. Additionally, if ever-so-apologetic-yet-careless HTC ever gets their 2.1 update released; that may fix it too(?), who knows.

      • Steven Rothkin commented  · 

        Motorola Droid.

        In timeriffic I can choose ringer mute and vibrate on for
        everything. The vibrate icon appears in the notification area when
        this is active. More important, calendar and Astrid alarms still
        vibrate but don't make noise (unlike silent mode where those don't
        vibrate).

        It would be nice to have a similar option in SP. Currently if I choose
        silent, the notification vibrate option is grayed out. If I choose to
        simply set all volumes to 0 there is no indication of that in the
        notification area.

      • gpoete commented  · 

        On my Hero (Android 1.5), the vibrate-icon shows up correctly if both of the following conditions are met in the active profile:
        - Silent mode is starred and set
        - Vibrate for call is starred and set
        If Vibrate for call is not set, the Silent icon will shows up instead. I think it is a normal behavior.
        The only thing that can be improved in SP, is the "Vibrate on notifications" option when in silent mode, as this propertie is dimmed (cannot be changed nor starred) in the profile menu when Silent mode is set before, here is the key point!
        Below is the solution I found:
        - to keep on the phone vibrate on notifications when setting Silent mode, set the "Vibrate on notifications" option BEFORE setting the Silent mode, as it will be dimmed after, so set or unset according to the current value.
        What I suggest in SP, is to allow (undim) the "Vibrate on notifications" option when Silent mode is set, so that the user can choose the notification behavior in silent mode: vibrate ... or really silent!
        Hope that it will help, and that I was clear enough ;-)
        BR,
        Gilleshander,

      • riccot commented  · 

        ok, this way it works, the other way by just turning ringer volume down it doesn't. but that's not very impotant imho

      • NetGenSuperstar commented  · 

        I can get Vibrate mode to work on my G1 (Android 1.6) by enabling "Silent mode" but keeping "Vibrate for calls" enabled as well. If this doesn't work on your phone, it's probably related to the bug mentioned by probeez.

      • riccot commented  · 

        It doesn't show on the nexus one. I just turned the ringer volume all the way down in the profile. Is that usually enough?

      • Mark Hirt commented  · 

        The "vibration-icon does show on my Sprint Hero

      Feedback and Knowledge Base